<!doctype html>
<html lang="en">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
 <meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
 <meta name="google-site-verification" content="u8szh2ZiMut0IxmoUC8xfDZSyxxnVZPVlWcTnQ-rcD0" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="viewport" content="width=1040">


<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script> 
<link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet">
<link rel="stylesheet" href="https://macondaily.com/wp-content/themes/alambre/style.css?1521124003" type="text/css" media="screen, projection" />

<link href="https://macondaily.com/feed" rel="alternate" title="Macon Daily RSS Feed" type="application/rss+xml" />
<link href="https://macondaily.com/feed/atom" rel="alternate" title="Macon Daily Atom Feed" type="application/atom+xml" />
<link href="https://macondaily.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Macon Daily &raquo; Prudential Financial (PRU) Receives $117.82 Average Target Price from Analysts Comments Feed" href="https://macondaily.com/2018/03/31/prudential-financial-pru-receives-117-82-average-target-price-from-analysts.html/feed" />
<link rel='https://api.w.org/' href='https://macondaily.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://macondaily.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://macondaily.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='AMP Capital Investors Ltd Acquires 9,800 Shares of Federated Investors Inc (FII)' href='https://macondaily.com/2018/03/31/federated-investors-inc-fii-shares-bought-by-amp-capital-investors-ltd-updated.html' />
<link rel='next' title='Mondelez International Inc (MDLZ) Short Interest Update' href='https://macondaily.com/2018/03/31/mondelez-international-inc-mdlz-short-interest-update.html' />
<meta name="generator" content="WordPress 4.9.4" />
<link rel="canonical" href="https://macondaily.com/2018/03/31/prudential-financial-pru-receives-117-82-average-target-price-from-analysts.html" />
<link rel='shortlink' href='https://macondaily.com/?p=70492' />
<link rel="alternate" type="application/json+oembed" href="https://macondaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmacondaily.com%2F2018%2F03%2F31%2Fprudential-financial-pru-receives-117-82-average-target-price-from-analysts.html" />
<link rel="alternate" type="text/xml+oembed" href="https://macondaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmacondaily.com%2F2018%2F03%2F31%2Fprudential-financial-pru-receives-117-82-average-target-price-from-analysts.html&#038;format=xml" />
<link rel="amphtml" href="https://macondaily.com/2018/03/31/prudential-financial-pru-receives-117-82-average-target-price-from-analysts.html/amp" /><link rel="icon" href="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-04-65x65.png" sizes="32x32" />
<link rel="icon" href="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-04.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-04.png" />
<meta name="msapplication-TileImage" content="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-04.png" />

<!-- Start Meta Data -->

<title>Prudential Financial (PRU) Receives $117.82 Average Target Price from Analysts - Macon Daily</title>


<meta name="description" content="Shares of Prudential Financial (NYSE:PRU) have earned a consensus recommendation of &#8220;Buy&#8221; from the eighteen brokerages that are presently covering the firm, Marketbeat.com reports. One research analyst has rated the stock with a sell rating, six have given a hold rating, ten have issued a buy rating and one has assigned a strong buy rating [&hellip;]" />
<meta name="author" content="Michael Taylor">
<meta name="news_keywords" content="Prudential Financial,NYSE:PRU,PRU,Finance,74432010,Ratings,Consensus" />
<meta name="keywords" content="Prudential Financial,NYSE:PRU,PRU,Finance,74432010,Ratings,Consensus" />
<meta name="ticker" content="NYSE:PRU" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@RatingsNetwork" />
<meta name="twitter:title" content="Prudential Financial (PRU) Receives $117.82 Average Target Price from Analysts"/>
<meta name="twitter:description" content="Shares of Prudential Financial (NYSE:PRU) have earned a consensus recommendation of &#8220;Buy&#8221; from the eighteen brokerages that are presently covering the firm, Marketbeat.com reports. One research analyst has rated the stock with a sell rating, six have given a hold rating, ten have issued a buy rating and one has assigned a strong buy rating [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/prudential-financial-inc-logo.jpg" />

<!-- Open Graph Data -->
<meta property="og:title" content="Prudential Financial (PRU) Receives $117.82 Average Target Price from Analysts" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://macondaily.com/2018/03/31/prudential-financial-pru-receives-117-82-average-target-price-from-analysts.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/prudential-financial-inc-logo.jpg" />
<meta property="og:description" content="Shares of Prudential Financial (NYSE:PRU) have earned a consensus recommendation of &#8220;Buy&#8221; from the eighteen brokerages that are presently covering the firm, Marketbeat.com reports. One research analyst has rated the stock with a sell rating, six have given a hold rating, ten have issued a buy rating and one has assigned a strong buy rating [&hellip;]" />
<meta property="og:site_name" content="Macon Daily" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2018-03-31T06:56:30+0000" />
<meta property="article:modified_time" content="2018-03-31T06:56:30+0000" />
<meta property="article:tag" content="NYSE:PRU" />
<meta property="article:tag" content="Prudential Financial,NYSE:PRU,PRU,Finance,74432010,Ratings,Consensus" />
<meta property="article:section" content="stock-market" />

<!-- Google meta is in the body-->


	<meta name="googlebot" content="unavailable_after: 2018-05-30T06:56:30+0000" />
<!-- End Meta Data -->

<script type='text/javascript'>var PopupAdChannel=''; </script>

  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
  <script>
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "cc650ee4-3f73-44da-89c4-1311e5ef1a43",
      safari_web_id: 'web.onesignal.auto.596e7d36-250c-4e22-98d4-39c9730f6c95', 
      autoRegister: true,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1597t"
    }
    }]);
  </script>

  <script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

</head>

<body>

<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=11"></script>
	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Macon Daily', '', 'NYSE:PRU', 'Prudential Financial', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/prudential-financial-inc-logo.jpg');</script>
<!-- End MarketBeat Modern Popup -->

<header>

	<div class="width-limiter add-padding"><!-- start: width-limiter with logo and space for alternate header unit -->
		<a class="logo-link" href="https://macondaily.com"><img id="logo" src="/wp-content/uploads/2018/02/macon-daily-transparent-01.png" alt="Macon Daily logo"></a>
<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit">
<script type="text/javascript">
google_ad_client = AdClientID;
    google_ad_slot = "6680372270";
google_ad_width = 728;
google_ad_height = 90;
google_ad_channel="7513773936,8569953935"</script>
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div> 

<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->

	<div id="menu">
		<div class="width-limiter" id="nav-main">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-category-menu-header" class="menu"><li id="menu-item-748" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-748"><a href="https://macondaily.com/business">Business</a></li>
<li id="menu-item-749" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-749"><a href="https://macondaily.com/technology">Technology</a></li>
<li id="menu-item-750" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-750"><a href="https://macondaily.com/health">Health</a></li>
<li id="menu-item-751" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-751"><a href="https://macondaily.com/economy">Economy</a></li>
</ul></nav>
			<nav class="navigation"><ul id="menu-top-pages" class="menu"><li id="menu-item-756" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-756"><a href="https://macondaily.com/staff">Staff</a></li>
<li id="menu-item-757" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-757"><a href="https://macondaily.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-758" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-758"><a href="https://macondaily.com/about-contact">About/Contact</a></li>
</ul></nav>
				<form id="searchform" action="https://macondaily.com/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" placeholder="Search" />
						<input class="searchsubmit" type="submit" value="" />
					</div>
				</form><!-- end: searchform -->
		</div> <!-- end: width-limiter for menu -->

	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter main-content">
		
<aside>
<!-- first square unit -->

<div>
<!-- Begin Dianomi Unit -->
<iframe width="336" height="670" scrolling="NO" src="//www.dianomi.com/smartads.epl?id=3355" style="width: 336px; border: none; overflow: hidden;"></iframe>
<!-- End Dianomi Unit -->
	
<div class="ad336x280">
 <script type="text/javascript">
 google_ad_client = AdClientID;
 /* Ticker 300 */
    google_ad_slot = "2860492869";
 google_ad_width = 336;
 google_ad_height = 280;
 google_ad_channel="7513773936,9582167132"+PopupAdChannel; </script>
 <script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
 </script>
</div>

<!-- end first square unit -->

<!-- second square unit -->
<div class="ad336x280">
 <script type="text/javascript">
 google_ad_client = AdClientID;
 /* Ticker 300 */
google_ad_slot = "2860492869";
 google_ad_width = 336;
 google_ad_height = 280;
 google_ad_channel="7513773936,2058900337"+PopupAdChannel; </script>
 <script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
 </script>
</div>

<!-- end second square unit -->


<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Prudential Financial</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Prudential Financial with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Macon Daily-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:PRU" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->


<div>
<a href="https://twitter.com/macondailynews" class="twitter-follow-button" data-show-count="false">Follow @macondailynews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</div>

<iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2FMacon-Daily-1815157661849118%2F&tabs=timeline&width=336&height=70&small_header=true&adapt_container_width=true&hide_cover=false&show_facepile=true&appId" width="336" height="70" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>


<!-- start sponsored posts 
    <div>
    <iframe width="336" height="450" scrolling="no" src="//www.dianomi.com/smartads.epl?id=3356"></iframe>
    </div>
 end sponsored posts -->


<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent Posts</h3>
            <ul>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/harris-co-hrs-expected-to-announce-earnings-of-1-64-per-share-updated.html">Harris Co. (HRS) Expected to Announce Earnings of $1.64 Per Share</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/sanderson-farms-safm-vs-treehouse-foods-ths-critical-survey-updated.html">Head-To-Head Review: Sanderson Farms (SAFM) versus TreeHouse Foods (THS)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/zenyatta-ventures-zenyf-its-peers-financial-survey-updated.html">Critical Review: Zenyatta Ventures (OTCMKTS:ZENYF) versus Its Peers</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/shenandoah-telecommunications-shen-and-its-competitors-financial-survey-updated.html">Reviewing Shentel (NASDAQ:SHEN) &amp; Its Peers</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/contrasting-brookdale-senior-living-bkd-its-rivals-updated.html">Brookdale Senior Living (BKD) vs. Its Competitors Head to Head Survey</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/halozyme-therapeutics-halo-and-eisai-esaly-head-to-head-survey-updated.html">Head to Head Analysis: Eisai (ESALY) &amp; Halozyme Therapeutics (HALO)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/aurumcoin-au-price-up-54-4-this-week-updated.html">AurumCoin Trading Down 32.9% Over Last Week (AU)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/version-achieves-market-cap-of-1-43-million-v-updated.html">Version Trading Down 31.9% Over Last Week (V)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/grubhub-inc-grub-cfo-sells-242617-50-in-stock-updated.html">GrubHub Inc (NYSE:GRUB) CFO Sells $242,617.50 in Stock</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/centurion-trading-down-21-2-over-last-7-days-cnt-updated.html">Centurion Trading Down 52.3% Over Last Week (CNT)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/intevac-ivac-oclaro-oclr-head-to-head-contrast-updated.html">Intevac (IVAC) versus Oclaro (OCLR) Head-To-Head Review</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/critical-contrast-rice-midstream-partners-rmp-vs-kimbell-royalty-partners-krp-updated.html">Head-To-Head Review: Kimbell Royalty Partners (KRP) versus Rice Midstream Partners (RMP)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/cornerstone-capital-management-holdings-llc-buys-shares-of-35823-consol-energy-inc-ceix.html">Cornerstone Capital Management Holdings LLC. Buys Shares of 35,823 Consol Energy Inc (CEIX)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/cornerstone-capital-management-holdings-llc-cuts-stake-in-first-foundation-ffwm.html">Cornerstone Capital Management Holdings LLC. Cuts Stake in First Foundation (FFWM)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/depomed-depo-stake-raised-by-cornerstone-capital-management-holdings-llc.html">Depomed (DEPO) Stake Raised by Cornerstone Capital Management Holdings LLC.</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/conning-inc-increases-stake-in-alphabet-inc-goog.html">Conning Inc. Increases Stake in Alphabet Inc (GOOG)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/cetera-advisors-llc-cuts-position-in-oracle-co-orcl.html">Cetera Advisors LLC Cuts Position in Oracle Co. (ORCL)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/unifirst-corp-unf-vp-sells-148950-00-in-stock.html">UniFirst Corp (UNF) VP Sells $148,950.00 in Stock</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/gentex-gntx-to-go-ex-dividend-on-april-5th.html">Gentex (GNTX) To Go Ex-Dividend on April 5th</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/03/31/trupanion-trup-insider-sells-118840-00-in-stock.html">Trupanion (TRUP) Insider Sells $118,840.00 in Stock</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->
		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://macondaily.com/2018/03/31/prudential-financial-pru-receives-117-82-average-target-price-from-analysts.html" />
				<div class="page-title">
				<h1 itemprop="headline">Prudential Financial (PRU) Receives $117.82 Average Target Price from Analysts</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://macondaily.com/author/michaelt" title="Posts by Michael Taylor" rel="author">Michael Taylor</a></span></span> on <span itemprop="datePublished dateModified" content="2018-03-31T06:56:30+0000">Mar 31st, 2018</span> 
				</p><!--end .postmeta-->

				<!-- social sharing -->

				<div style="float:left; width:70px;"><g:plusone size="medium"></g:plusone></div>
				<div style="float:left; width:72px;">
				<a href="http://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-text="Prudential Financial (PRU) Receives $117.82 Average Target Price from Analysts" data-via="RatingsNetwork">Tweet</a>
				</div>
				<div style="float:left; width:85px;">
				<iframe src="https://www.facebook.com/plugins/share_button.php?href=https://macondaily.com/2018/03/31/prudential-financial-pru-receives-117-82-average-target-price-from-analysts.html&layout=button_count&size=small&mobile_iframe=true&appId=129801551471&width=87&height=20" width="87" height="20" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>
				</div>
				<div style="float:left; width:125px;">
				<script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
				<script type="IN/Share" data-counter="right"></script>
				</div>
				<div style="clear:both"></div>
				</div>
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/prudential-financial-inc-logo.jpg" alt="Prudential Financial logo" title="Prudential Financial logo" class="companylogo" />Shares of Prudential Financial (NYSE:PRU) have earned a consensus recommendation of &#8220;Buy&#8221; from the eighteen brokerages that are presently  covering the firm, <a href='https://www.marketbeat.com/'>Marketbeat.com</a> reports. One research analyst  has rated the stock with a sell rating, six have given a hold rating, ten have issued  a buy rating and one  has assigned  a strong buy rating to  the company. The average 1-year price objective among brokers that have issued a report on the stock in the last year is $117.82. </p>
<p>PRU has been the subject of several recent analyst reports. <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?Zacks=1'>Zacks Investment Research</a> cut shares of Prudential Financial from a &#8220;hold&#8221; rating to a &#8220;sell&#8221; rating in a report on Tuesday, March 20th. Keefe, Bruyette &#038; Woods  reiterated a &#8220;buy&#8221; rating and issued a $127.00 price objective on shares of Prudential Financial in a report on Thursday, December 21st. <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?ValuEngine=1&#038;Symbol=PRU'>ValuEngine</a> upgraded shares of Prudential Financial from a &#8220;buy&#8221; rating to a &#8220;strong-buy&#8221; rating in a report on Sunday, December 31st. Wells Fargo  set a $122.00 price objective on shares of Prudential Financial and gave the company a &#8220;hold&#8221; rating in a report on Thursday, December 14th. Finally, UBS upgraded shares of Prudential Financial from a &#8220;neutral&#8221; rating to a &#8220;buy&#8221; rating in a report on Friday, March 2nd.</p>
  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;">

<form method="get" action="https://www.marketbeat.com/subscribe.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Macon Daily"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:PRU" />    <label for="InPostRegistrationEmail">Get <b>Prudential Financial</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px" /></div>
</form>
<div id="ShowSuggestionInPost"></div>
				 </div>


<p><a href='https://www.marketbeat.com/stocks/NYSE/PRU/' target='_blank'>Prudential Financial stock</a> opened at $103.55 on Wednesday. The company has a quick ratio of 0.13, a current ratio of 0.13 and a debt-to-equity ratio of 0.32. The company has a market capitalization of $43,698.10, a PE ratio of 9.79, a P/E/G ratio of 1.07 and a beta of 1.54. Prudential Financial has a 12-month low of $97.88 and a 12-month high of $127.14. </p>

		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;">

<script type="text/javascript">
    google_ad_client = "ca-pub-9241026722326063";
    google_ad_slot = "2860492869";
    google_ad_width = 336;
    google_ad_height = 280;
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
                 </div>

					<p>Prudential Financial (NYSE:PRU) last posted its quarterly earnings data on Wednesday, February 7th. The financial services provider reported $2.69 earnings per share (EPS) for the quarter, beating the consensus estimate of $2.64 by $0.05. The business had revenue of $15.25 billion during the quarter, compared to analysts&#8217; expectations of $12.87 billion. Prudential Financial had a net margin of 13.41% and a return on equity of 9.29%. During the same period last year, the firm posted $2.46 earnings per share.  sell-side analysts anticipate that  Prudential Financial will post 12.07 EPS for the current fiscal year. </p>
<p>Prudential Financial announced that its board has approved a stock repurchase plan on Thursday, December 14th that allows the company to buyback $1.50 billion in    shares. This buyback authorization allows the financial services provider to purchase shares of its stock through open market purchases. Shares buyback plans are typically an indication that the company&#8217;s board of directors believes its shares are undervalued. </p>
<p>The firm also recently announced a quarterly dividend, which was paid on Thursday, March 15th. Investors of record on Wednesday, February 21st were paid a dividend of $0.90 per share. The ex-dividend date of this dividend  was Tuesday, February 20th. This is a positive change from Prudential Financial&#8217;s previous quarterly dividend of $0.75. This represents a $3.60 annualized dividend and a yield of 3.48%. Prudential Financial&#8217;s dividend payout ratio  is currently 34.03%. </p>
<p>In related news, SVP Barbara Koster sold 16,801 shares of the stock in a transaction that occurred on Tuesday, January 2nd. The shares were sold at an average price of $115.17, for a total transaction of $1,934,971.17. Following the completion of the sale, the senior vice president now directly owns 37,327 shares of the company&#8217;s stock, valued at $4,298,950.59. The transaction was disclosed in a document filed with the SEC, which can be accessed through <a href='http://www.sec.gov/Archives/edgar/data/1137774/000112760218000489/xslF345X03/form4.xml' target='_blank'>the SEC website</a>. Also, insider Stephen Pelletier sold 40,729 shares of the stock in a transaction that occurred on Wednesday, February 21st. The shares were sold at an average price of $108.75, for a total transaction of $4,429,278.75. The disclosure for this sale can be found <a href='http://www.sec.gov/Archives/edgar/data/1137774/000112760218007714/form4.xml' target='_blank'>here</a>. 0.66% of the stock is owned by corporate insiders. </p>
<p>A number of hedge funds have recently added to or reduced their stakes in PRU. Geode Capital Management LLC lifted its position in shares of  Prudential Financial by 3.2% in the 4th quarter. Geode Capital Management LLC now owns 4,456,237 shares of the financial services provider&#8217;s stock valued at $511,299,000 after acquiring an additional 137,541 shares in the last quarter.  Legal &#038; General Group Plc lifted its position in shares of  Prudential Financial by 2.3% in the 3rd quarter. Legal &#038; General Group Plc now owns 2,341,330 shares of the financial services provider&#8217;s stock valued at $248,931,000 after acquiring an additional 52,597 shares in the last quarter.  The Manufacturers Life Insurance Company  lifted its position in shares of  Prudential Financial by 1.7% in the 4th quarter. The Manufacturers Life Insurance Company  now owns 1,994,321 shares of the financial services provider&#8217;s stock valued at $229,307,000 after acquiring an additional 34,046 shares in the last quarter.  Millennium Management LLC lifted its position in shares of  Prudential Financial by 45.5% in the 4th quarter. Millennium Management LLC now owns 1,818,479 shares of the financial services provider&#8217;s stock valued at $209,089,000 after acquiring an additional 568,343 shares in the last quarter.  Finally, Wells Fargo &#038; Company MN lifted its position in shares of  Prudential Financial by 0.9% in the 4th quarter. Wells Fargo &#038; Company MN now owns 1,772,276 shares of the financial services provider&#8217;s stock valued at $203,776,000 after acquiring an additional 15,896 shares in the last quarter. 66.76% of the stock is owned by institutional investors and hedge funds. </p>
<div class='tdf79943ya'>TRADEMARK VIOLATION WARNING: This article was first  posted by Macon Daily and is owned by of Macon Daily. If you are viewing this article on another domain, it was illegally copied and reposted in violation of US and international copyright &amp; trademark legislation. The original version of this article can be viewed at https://macondaily.com/2018/03/31/prudential-financial-pru-receives-117-82-average-target-price-from-analysts.html. </div>
<p><strong>About Prudential Financial</strong></p>
<p>Prudential Financial, Inc, through its subsidiaries, provides insurance, investment management, and other financial products and services in the United States and internationally. It operates through U.S. Individual Solutions, U.S. Workplace Solutions, Investment Management, and International Insurance divisions.<!--ViewCount:ArticleHistoryID=16807335&PostDate=2018-3-31&type=c&secondary=1&id=361507--><!--Keyword: Prudential Financial,NYSE:PRU,PRU,Finance,74432010,Ratings,Consensus--><!--Ratings:4,14,NYSE:PRU--></p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/RatingsChart.ashx?Prefix=NYSE&#038;Symbol=PRU' alt='Analyst Recommendations for Prudential Financial (NYSE:PRU)' title='Analyst Recommendations for Prudential Financial (NYSE:PRU)' /></p>

			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Prudential Financial Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Prudential Financial and related companies with <a href="/daily-email-updates-basic/?symbol=NYSE:PRU&c=Prudential+Financial" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Macon Daily-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:PRU" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				<!--/sse-->
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=300&h=300&zc=1&src=https://www.marketbeat.com/logos/prudential-financial-inc-logo.jpg" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-01.png">
 						<meta itemprop="height" content="90">
						 <meta itemprop="width" content="280">
					 </div>
					<meta itemprop="name" content="Macon Daily"/>
					<meta itemprop="url" content="https://macondaily.com" />
 				</div>
				<!-- end article metadata -->

			</article>

			<!-- start Dianomi – sponsored content -->
			<iframe style="max-width:100%" width="654" height="787" scrolling="no" src="//www.dianomi.com/smartads.epl?id=2341"></iframe>
			<!-- end sponsored content -->

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://macondaily.com/2018/03/31/federated-investors-inc-fii-shares-bought-by-amp-capital-investors-ltd-updated.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>AMP Capital Investors Ltd Acquires 9,800 Shares of Federated Investors Inc (FII)</p></div></a>				<a href="https://macondaily.com/2018/03/31/mondelez-international-inc-mdlz-short-interest-update.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>Mondelez International Inc (MDLZ) Short Interest Update</p></div></a>			
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>More Articles</h2>
			 				 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/harris-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Harris Co.  Expected to Announce Earnings of $1.64 Per Share" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2018/03/31/harris-co-hrs-expected-to-announce-earnings-of-1-64-per-share-updated.html" rel="bookmark">Harris Co.  Expected to Announce Earnings of $1.64 Per Share</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/sanderson-farms-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Head-To-Head Review: Sanderson Farms  versus TreeHouse Foods " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2018/03/31/sanderson-farms-safm-vs-treehouse-foods-ths-critical-survey-updated.html" rel="bookmark">Head-To-Head Review: Sanderson Farms  versus TreeHouse Foods </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/zenyatta-ventures-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Critical Review: Zenyatta Ventures  versus Its Peers" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2018/03/31/zenyatta-ventures-zenyf-its-peers-financial-survey-updated.html" rel="bookmark">Critical Review: Zenyatta Ventures  versus Its Peers</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/shenandoah-telecommunications-co-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Reviewing Shentel  &amp; Its Peers" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2018/03/31/shenandoah-telecommunications-shen-and-its-competitors-financial-survey-updated.html" rel="bookmark">Reviewing Shentel  &amp; Its Peers</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/brookdale-senior-living-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Brookdale Senior Living  vs. Its Competitors Head to Head Survey" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2018/03/31/contrasting-brookdale-senior-living-bkd-its-rivals-updated.html" rel="bookmark">Brookdale Senior Living  vs. Its Competitors Head to Head Survey</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/eisai-co-ltd-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Head to Head Analysis: Eisai  &amp; Halozyme Therapeutics " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2018/03/31/halozyme-therapeutics-halo-and-eisai-esaly-head-to-head-survey-updated.html" rel="bookmark">Head to Head Analysis: Eisai  &amp; Halozyme Therapeutics </a>
				</div>
	 						</div><!-- end latest news -->

			<!-- start comments section -->
					
				
<div class="comments-box">
	<a name="comments" id="comments"></a>
	
<div id="respond">
	<h3>Leave a Reply</h3>
	<div class="cancel-comment-reply"> 
		<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/03/31/prudential-financial-pru-receives-117-82-average-target-price-from-analysts.html#respond" style="display:none;">Click here to cancel reply.</a></small>
	</div> 
			<form action="https://macondaily.com/wp-comments-post.php" method="post" id="commentform">
 			
			<p>
				<input type="text" name="author" class="txt" id="author" value="" size="22" tabindex="1" />
				<label for="author">Name  (Required) </label>
			</p>
			<p>
				<input type="text" name="email" class="txt" id="email" value="" size="22" tabindex="2" />
				<label for="email">Mail (will not be published)  (Required) </label>
			</p>
			<p>
				<input type="text" name="url" class="txt" id="url" value="" size="22" tabindex="3" />
				<label for="url">Website</label>
			</p>

						<p><textarea autocomplete="nope"  id="a9d2bc0532"  name="1d9a7a4e56"   rows="10" cols="50" tabindex="4"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="nope" style="clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script type="text/javascript">document.getElementById("comment").setAttribute( "id", "4930b7703db6ea09af963b132e0227f6" );document.getElementById("a9d2bc0532").setAttribute( "id", "comment" );</script></p>
			<input name="submit" type="submit" id="submit" class="button" tabindex="5" value="Submit Comment" />
			<input type="hidden" name="comment_post_ID" value="70492" />
			<input type='hidden' name='comment_post_ID' value='70492' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
					</form> 
</div> 
</div> 			<!-- end comments section --> 


<!-- second ad spot -->


<br>
	</main> <!-- end main -->

	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-category-menu-header-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-748"><a href="https://macondaily.com/business">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-749"><a href="https://macondaily.com/technology">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-750"><a href="https://macondaily.com/health">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-751"><a href="https://macondaily.com/economy">Economy</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2006-2018 <a href="https://macondaily.com">Macon Daily</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://macondaily.com/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
	
<!-- Start of StatCounter Code for Macon Daily -->
<script type="text/javascript">
var sc_project=11096465; 
var sc_invisible=1; 
var sc_security="ab3f5b90"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/11096465/0/ab3f5b90/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Macon Daily -->

		
	<!-- Start of StatCounter Code for Finance Articles -->
		<script type="text/javascript">
		var sc_project=9021069; 
		var sc_invisible=1; 
		var sc_security="fdde5482"; 
		var sc_https=1; 
		document.write("<sc"+"ript type='text/javascript' src='https://www.statcounter.com/counter/counter.js'></" + "script>");
		</script>
		<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/"></noscript>
		<!-- End of StatCounter Code for Finance Articles -->
		
<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=16807335&PostDate=2018-3-31&type=c&secondary=1&id=361507&domain=macondaily.com&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->


<!-- Start of StatCounter Code for Updated Articles -->
<!-- End of StatCounter Code for Updated Articles -->

<!-- One Signal Registration Code -->
<script type="text/javascript">
if(OneSignal.isPushNotificationsSupported())
{
    OneSignal.registerForPushNotifications();
}
</script>
<!-- End Registration Code -->


	</body>

</html>