<!doctype html>
<html lang="en">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
 <meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
 <meta name="google-site-verification" content="u8szh2ZiMut0IxmoUC8xfDZSyxxnVZPVlWcTnQ-rcD0" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="viewport" content="width=1040">


<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script> 
<link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet">
<link rel="stylesheet" href="https://macondaily.com/wp-content/themes/alambre/style.css?1521124003" type="text/css" media="screen, projection" />

<link href="https://macondaily.com/feed" rel="alternate" title="Macon Daily RSS Feed" type="application/rss+xml" />
<link href="https://macondaily.com/feed/atom" rel="alternate" title="Macon Daily Atom Feed" type="application/atom+xml" />
<link href="https://macondaily.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Macon Daily &raquo; Albemarle (ALB) Hits New 1-Year Low at $84.01 Comments Feed" href="https://macondaily.com/2018/12/14/albemarle-alb-hits-new-1-year-low-at-84-01.html/feed" />
<link rel='https://api.w.org/' href='https://macondaily.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://macondaily.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://macondaily.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Worldquant Millennium Quantitative Strategies LLC Buys 7,786 Shares of Best Buy Co Inc (BBY)' href='https://macondaily.com/2018/12/14/worldquant-millennium-quantitative-strategies-llc-buys-7786-shares-of-best-buy-co-inc-bby.html' />
<link rel='next' title='Ralph Lauren Corp (RL) Position Raised by Point72 Asset Management L.P.' href='https://macondaily.com/2018/12/14/ralph-lauren-corp-rl-position-raised-by-point72-asset-management-l-p.html' />
<meta name="generator" content="WordPress 4.9.9" />
<link rel="canonical" href="https://macondaily.com/2018/12/14/albemarle-alb-hits-new-1-year-low-at-84-01.html" />
<link rel='shortlink' href='https://macondaily.com/?p=1402819' />
<link rel="alternate" type="application/json+oembed" href="https://macondaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmacondaily.com%2F2018%2F12%2F14%2Falbemarle-alb-hits-new-1-year-low-at-84-01.html" />
<link rel="alternate" type="text/xml+oembed" href="https://macondaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmacondaily.com%2F2018%2F12%2F14%2Falbemarle-alb-hits-new-1-year-low-at-84-01.html&#038;format=xml" />
<link rel="amphtml" href="https://macondaily.com/2018/12/14/albemarle-alb-hits-new-1-year-low-at-84-01.html/amp" /><link rel="icon" href="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-04-65x65.png" sizes="32x32" />
<link rel="icon" href="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-04.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-04.png" />
<meta name="msapplication-TileImage" content="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-04.png" />

<!-- Start Meta Data -->

<title>Albemarle (ALB) Hits New 1-Year Low at $84.01 - Macon Daily</title>


<meta name="description" content="Shares of Albemarle Co. (NYSE:ALB) hit a new 52-week low during trading on Friday . The stock traded as low as $84.01 and last traded at $84.33, with a volume of 840852 shares trading hands. The stock had previously closed at $87.94. A number of equities analysts have issued reports on the stock. Zacks Investment [&hellip;]" />
<meta name="author" content="Emily Bradson">
<meta name="news_keywords" content="Albemarle,NYSE:ALB,ALB,Basic Material,01265310,Stocks,Technicals" />
<meta name="keywords" content="Albemarle,NYSE:ALB,ALB,Basic Material,01265310,Stocks,Technicals" />
<meta name="ticker" content="NYSE:ALB" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@RatingsNetwork" />
<meta name="twitter:title" content="Albemarle (ALB) Hits New 1-Year Low at $84.01"/>
<meta name="twitter:description" content="Shares of Albemarle Co. (NYSE:ALB) hit a new 52-week low during trading on Friday . The stock traded as low as $84.01 and last traded at $84.33, with a volume of 840852 shares trading hands. The stock had previously closed at $87.94. A number of equities analysts have issued reports on the stock. Zacks Investment [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/albemarle-corp-logo.gif" />

<!-- Open Graph Data -->
<meta property="og:title" content="Albemarle (ALB) Hits New 1-Year Low at $84.01" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://macondaily.com/2018/12/14/albemarle-alb-hits-new-1-year-low-at-84-01.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/albemarle-corp-logo.gif" />
<meta property="og:description" content="Shares of Albemarle Co. (NYSE:ALB) hit a new 52-week low during trading on Friday . The stock traded as low as $84.01 and last traded at $84.33, with a volume of 840852 shares trading hands. The stock had previously closed at $87.94. A number of equities analysts have issued reports on the stock. Zacks Investment [&hellip;]" />
<meta property="og:site_name" content="Macon Daily" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2018-12-14T16:14:41+0000" />
<meta property="article:modified_time" content="2018-12-14T16:14:41+0000" />
<meta property="article:tag" content="NYSE:ALB" />
<meta property="article:tag" content="Albemarle,NYSE:ALB,ALB,Basic Material,01265310,Stocks,Technicals" />
<meta property="article:section" content="stock-market" />

<!-- Google meta is in the body-->


	<meta name="googlebot" content="unavailable_after: 2019-02-12T16:14:41+0000" />
<!-- End Meta Data -->

	
<script type='text/javascript'>var PopupAdChannel=''; </script>

  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'macondaily.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "cc650ee4-3f73-44da-89c4-1311e5ef1a43",
      safari_web_id: 'web.onesignal.auto.596e7d36-250c-4e22-98d4-39c9730f6c95', 
      autoRegister: true,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
  </script>

  <script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<!-- Start IMS -->
<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13481304,
				sizes: [[300,250],[300,600],[300,1050]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'MaconDaily_ROS_RightRail_1'
			});
					});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		</script>
<!-- End IMS --> 

	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
		<!-- ManyChat -->
<script src="//widget.manychat.com/1450892295227696.js" async="async">
</script>
	
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
</head>

<body>

<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=36"></script>
<script>
	    if (Notification.permission == "denied") { showsecondarynotifications('Macon Daily', 'https://www.marketbeat.com/images/webpush/macon-daily-04.png');}
</script>	

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Macon Daily', 'macondaily.com', 'NYSE:ALB', 'Albemarle', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/albemarle-corp-logo.gif');</script>
<!-- End MarketBeat Modern Popup -->

<header>

	<div class="width-limiter add-padding"><!-- start: width-limiter with logo and space for alternate header unit -->
		<a class="logo-link" href="https://macondaily.com"><img id="logo" src="/wp-content/uploads/2018/02/macon-daily-transparent-01.png" alt="Macon Daily logo"></a>
<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit">
<script type="text/javascript">
google_ad_client = AdClientID;
    google_ad_slot = "6680372270";
google_ad_width = 728;
google_ad_height = 90;
google_ad_channel="6874771534,8569953935"</script>
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div> 

<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->

	<div id="menu">
		<div class="width-limiter" id="nav-main">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-category-menu-header" class="menu"><li id="menu-item-748" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-748"><a href="https://macondaily.com/business">Business</a></li>
<li id="menu-item-749" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-749"><a href="https://macondaily.com/technology">Technology</a></li>
<li id="menu-item-750" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-750"><a href="https://macondaily.com/health">Health</a></li>
<li id="menu-item-751" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-751"><a href="https://macondaily.com/economy">Economy</a></li>
</ul></nav>
			<nav class="navigation"><ul id="menu-top-pages" class="menu"><li id="menu-item-756" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-756"><a href="https://macondaily.com/staff">Staff</a></li>
<li id="menu-item-757" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-757"><a href="https://macondaily.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-758" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-758"><a href="https://macondaily.com/about-contact">About/Contact</a></li>
</ul></nav>
				<form id="searchform" action="https://macondaily.com/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" placeholder="Search" />
						<input class="searchsubmit" type="submit" value="" />
					</div>
				</form><!-- end: searchform -->
		</div> <!-- end: width-limiter for menu -->

	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter main-content">
		
<aside>
	
<!-- first square unit -->

<!-- Begin Dianomi Unit -->
<iframe width="336" height="670" scrolling="NO" src="//www.dianomi.com/smartads.epl?id=3356" style="width: 336px; border: none; overflow: hidden;"></iframe>
<!-- End Dianomi Unit -->

<div class="ad336x280">
 <script type="text/javascript">
 google_ad_client = AdClientID;
 /* Ticker 300 */
    google_ad_slot = "2860492869";
 google_ad_width = 336;
 google_ad_height = 280;
 google_ad_channel="6874771534,9582167132"+PopupAdChannel; </script>
 <script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
 </script>
</div>

<!-- end first square unit -->

<!-- second square unit -->
<div class="ad336x280">
 <script type="text/javascript">
 google_ad_client = AdClientID;
 /* Ticker 300 */
google_ad_slot = "2860492869";
 google_ad_width = 336;
 google_ad_height = 280;
 google_ad_channel="6874771534,2058900337"+PopupAdChannel; </script>
 <script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
 </script>
</div>

<!-- end second square unit -->
	
<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Albemarle</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Albemarle with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Macon Daily-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:ALB" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->


<div>
<a href="https://twitter.com/macondailynews" class="twitter-follow-button" data-show-count="false">Follow @macondailynews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</div>

<iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2FMacon-Daily-1815157661849118%2F&tabs=timeline&width=336&height=70&small_header=true&adapt_container_width=true&hide_cover=false&show_facepile=true&appId" width="336" height="70" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>


<!-- Start IMS -->
<div id="MaconDaily_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('MaconDaily_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- End IMS --> 

<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent Posts</h3>
            <ul>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/national-bank-of-canada-na-insider-ricardo-pascoe-sells-49884-shares.html">National Bank of Canada (NA) Insider Ricardo Pascoe Sells 49,884 Shares</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/carvana-co-cvna-shares-bought-by-point72-asset-management-l-p.html">Carvana Co (CVNA) Shares Bought by Point72 Asset Management L.P.</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/baidu-inc-bidu-shares-sold-by-point72-asia-singapore-pte-ltd.html">Baidu Inc (BIDU) Shares Sold by Point72 Asia Singapore Pte. Ltd.</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/ralph-lauren-corp-rl-position-raised-by-point72-asset-management-l-p.html">Ralph Lauren Corp (RL) Position Raised by Point72 Asset Management L.P.</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/point72-hong-kong-ltd-buys-20747-shares-of-roku-inc-roku.html">Point72 Hong Kong Ltd Buys 20,747 Shares of Roku Inc (ROKU)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/british-american-tobacco-bti-sets-new-52-week-low-at-33-10.html">British American Tobacco (BTI) Sets New 52-Week Low at $33.10</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/albemarle-alb-hits-new-1-year-low-at-84-01.html">Albemarle (ALB) Hits New 1-Year Low at $84.01</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/worldquant-millennium-quantitative-strategies-llc-buys-7786-shares-of-best-buy-co-inc-bby.html">Worldquant Millennium Quantitative Strategies LLC Buys 7,786 Shares of Best Buy Co Inc (BBY)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/reviewing-technicolor-tclry-and-arlo-technologies-arlo.html">Reviewing Technicolor (TCLRY) and Arlo Technologies (ARLO)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/point72-hong-kong-ltd-buys-new-position-in-pinduoduo-inc-pdd.html">Point72 Hong Kong Ltd Buys New Position in Pinduoduo Inc (PDD)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/primo-water-prmw-vs-dts8-coffee-bkct-head-to-head-survey.html">Primo Water (PRMW) vs. DTS8 Coffee (BKCT) Head to Head Survey</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/comparing-piedmont-lithiu-s-plll-its-rivals.html">Comparing PIEDMONT LITHIU/S (PLLL) &amp; Its Rivals</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/advanced-micro-devices-inc-amd-shares-sold-by-point72-hong-kong-ltd.html">Advanced Micro Devices, Inc. (AMD) Shares Sold by Point72 Hong Kong Ltd</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/point72-asset-management-l-p-boosts-position-in-agilent-technologies-inc-a.html">Point72 Asset Management L.P. Boosts Position in Agilent Technologies Inc (A)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/point72-europe-london-llp-purchases-14500-shares-of-keycorp-key.html">Point72 Europe London LLP Purchases 14,500 Shares of KeyCorp (KEY)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/pointstate-capital-lp-grows-position-in-shire-plc-shpg.html">PointState Capital LP Grows Position in Shire PLC (SHPG)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/pointstate-capital-lp-purchases-shares-of-633710-ptc-inc-ptc.html">PointState Capital LP Purchases Shares of 633,710 PTC Inc (PTC)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/philadelphia-financial-management-of-san-francisco-llc-buys-461454-shares-of-bgc-partners-inc-bgcp.html">Philadelphia Financial Management of San Francisco LLC Buys 461,454 Shares of BGC Partners, Inc. (BGCP)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/the-carlyle-group-lp-cg-stake-lessened-by-philadelphia-financial-management-of-san-francisco-llc.html">The Carlyle Group LP (CG) Stake Lessened by Philadelphia Financial Management of San Francisco LLC</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2018/12/14/1-55-earnings-per-share-expected-for-mid-america-apartment-communities-inc-maa-this-quarter.html">$1.55 Earnings Per Share Expected for Mid-America Apartment Communities Inc (MAA) This Quarter</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->
		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://macondaily.com/2018/12/14/albemarle-alb-hits-new-1-year-low-at-84-01.html" />
				<div class="page-title">
				<h1 itemprop="headline">Albemarle (ALB) Hits New 1-Year Low at $84.01</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://macondaily.com/author/emilyb" title="Posts by Emily Bradson" rel="author">Emily Bradson</a></span></span> on <span itemprop="datePublished dateModified" content="2018-12-14T16:14:41+0000">Dec 14th, 2018</span> 
				</p><!--end .postmeta-->

				<!-- social sharing -->
				<div style="float:left; width:72px;">
				<a href="http://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-text="Albemarle (ALB) Hits New 1-Year Low at $84.01" data-via="RatingsNetwork">Tweet</a>
				</div>
				<div style="float:left; width:85px;">
				<iframe src="https://www.facebook.com/plugins/share_button.php?href=https://macondaily.com/2018/12/14/albemarle-alb-hits-new-1-year-low-at-84-01.html&layout=button_count&size=small&mobile_iframe=true&appId=129801551471&width=87&height=20" width="87" height="20" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>
				</div>
				<div style="float:left; width:77px;">
				<script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
				<script type="IN/Share" data-counter="right"></script>
				</div>
										<div style="float:left;width:112px">
						<a href="https://api.stocktwits.com/widgets/share" id="stocktwits-share-button" data-text="Albemarle (ALB) Hits New 1-Year Low at $84.01 $ALB "><img src="https://api.stocktwits.com/assets/widget/stocktwits_share.png" alt="Share on StockTwits"/></a><script src="https://api.stocktwits.com/addon/button/share.min.js"></script>	
					</div>
	
				<div style="clear:both"></div>
				</div>
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/albemarle-corp-logo.gif" alt="Albemarle logo" title="Albemarle logo" class="companylogo" />Shares of Albemarle Co. (NYSE:ALB) hit a new 52-week low during trading on Friday . The stock traded as low as $84.01 and last traded at $84.33, with a volume of 840852 shares trading hands. The stock had previously closed at $87.94.</p>
<p>A number of equities analysts have issued reports on the stock. <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?Zacks=1'>Zacks Investment Research</a> cut shares of Albemarle from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating in a research report on Tuesday, November 27th. <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?ValuEngine=1&#038;Symbol=ALB'>ValuEngine</a> cut shares of Albemarle from a &#8220;hold&#8221; rating to a &#8220;sell&#8221; rating in a research report on Wednesday, November 28th. HSBC assumed coverage on shares of Albemarle in a research report on Sunday, December 9th. They set a &#8220;hold&#8221; rating and a $96.32 target price for the company. Buckingham Research assumed coverage on shares of Albemarle in a research report on Thursday, November 15th. They set a &#8220;neutral&#8221; rating and a $106.00 target price for the company. Finally, Berenberg Bank  set a $130.00 target price on shares of Albemarle and gave the stock a &#8220;buy&#8221; rating in a research report on Friday, November 9th. Three investment analysts have rated the stock with a sell rating, one  has given a hold rating and nineteen have given a buy rating to the stock. The stock currently has an average rating of &#8220;Buy&#8221; and an average price target of $121.91.</p>


<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Macon Daily"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:ALB" />    <label for="InPostRegistrationEmail">Get <b>Albemarle</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>
		


<p>The company has a debt-to-equity ratio of 0.38, a quick ratio of 1.18 and a current ratio of 1.83. The stock has a market cap of $9.43 billion, a price-to-earnings ratio of 18.51, a P/E/G ratio of 1.01 and a beta of 1.52. </p>

		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;">

<script type="text/javascript">
    google_ad_client = "ca-pub-9241026722326063";
    google_ad_slot = "2860492869";
    google_ad_width = 336;
    google_ad_height = 280;
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
                 </div>

					<p>Albemarle (NYSE:ALB) last posted its quarterly earnings data on Wednesday, November 7th. The specialty chemicals company reported $1.31 earnings per share for the quarter, beating analysts&#8217; consensus estimates of $1.25 by $0.06. The business had revenue of $778.00 million during the quarter, compared to analyst estimates of $796.79 million. Albemarle had a net margin of 10.44% and a return on equity of 15.39%. The company&#8217;s revenue was up 3.0% on a year-over-year basis. During the same quarter in the previous year, the business posted $1.08 earnings per share.  Research analysts anticipate that  Albemarle Co. will post 5.43 earnings per share for the current fiscal year. </p>
<p>The company also recently disclosed a quarterly dividend, which will be paid on Wednesday, January 2nd. Stockholders of record on Friday, December 14th will be given a $0.335 dividend. This represents a $1.34 dividend on an annualized basis and a dividend yield of 1.58%. The ex-dividend date of this dividend is Thursday, December 13th. Albemarle&#8217;s dividend payout ratio  is presently 29.19%. </p>
<p>In other news, EVP Karen G. Narwold sold 3,100 shares of the business&#8217;s stock in a transaction that occurred on Monday, November 26th. The shares were sold at an average price of $96.54, for a total value of $299,274.00. Following the completion of the transaction, the executive vice president now owns 27,142 shares of the company&#8217;s stock, valued at $2,620,288.68. The transaction was disclosed in a document filed with the SEC, which is accessible through <a href='http://www.sec.gov/Archives/edgar/data/915913/000091591318000049/xslF345X03/wf-form4_154335908780955.xml' target='_blank'>this link</a>. Insiders own  0.80% of the company&#8217;s stock. </p>
<p>Large investors have recently bought and sold shares of the company. Rehmann Capital Advisory Group grew its holdings in  Albemarle by 3,087.5% in the third quarter. Rehmann Capital Advisory Group now owns 255 shares of the specialty chemicals company&#8217;s stock valued at $25,000 after purchasing an additional 247 shares during the period.  Credit Agricole S A purchased a new stake in  Albemarle in the second quarter valued at approximately $123,000.  Valeo Financial Advisors LLC grew its holdings in  Albemarle by 17,210.0% in the third quarter. Valeo Financial Advisors LLC now owns 1,731 shares of the specialty chemicals company&#8217;s stock valued at $171,000 after purchasing an additional 1,721 shares during the period.  Evercore Wealth Management LLC purchased a new stake in  Albemarle in the third quarter valued at approximately $202,000.  Finally, Palladium Partners LLC purchased a new stake in  Albemarle in the third quarter valued at approximately $205,000. 92.73% of the stock is owned by institutional investors and hedge funds. </p>
<p><span id='dy2acplogp'>COPYRIGHT VIOLATION NOTICE: This piece of content was first  published by Macon Daily and is the property of of Macon Daily. If you are viewing this piece of content on another domain, it was copied illegally and reposted in violation of US &amp; international copyright &amp; trademark laws. The legal version of this piece of content can be viewed at https://macondaily.com/2018/12/14/albemarle-alb-hits-new-1-year-low-at-84-01.html. </span></p>
<p><strong>Albemarle Company Profile</strong> (<a href='https://www.marketbeat.com/stocks/NYSE/ALB/'>NYSE:ALB</a>)</p>
<p>Albemarle Corporation develops, manufactures, and markets engineered specialty chemicals worldwide. Its Lithium and Advanced Materials segment offers lithium compounds, including lithium carbonate, lithium hydroxide, lithium chloride, and lithium specialties, as well as reagents, such as butyllithium and lithium aluminum hydride for applications in lithium batteries for consumer electronics and automobiles, high performance greases, thermoplastic elastomers for car tires, rubber soles, plastic bottles, catalysts for chemical reactions, organic synthesis processes, life science, pharmaceutical, and other markets.</p>
<p>Read More: <a href='https://www.marketbeat.com/financial-terms/12b-1-fees-affect-on-mutual-fund-performance/'>How prevalent are 12b-1 fees?</a><!--ViewCount:ArticleHistoryID=28152726&PostDate=2018-12-14&type=h&id=571967--><!--Keyword: Albemarle,NYSE:ALB,ALB,Basic Material,01265310,Stocks,Technicals--><!--Ratings:4,21,NYSE:ALB--></p>

			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Albemarle Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Albemarle and related companies with <a href="/daily-email-updates-basic/?symbol=NYSE:ALB&c=Albemarle" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Macon Daily-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:ALB" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				<!--/sse-->
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=300&h=300&zc=1&src=https://www.marketbeat.com/logos/albemarle-corp-logo.gif" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-01.png">
 						<meta itemprop="height" content="90">
						 <meta itemprop="width" content="280">
					 </div>
					<meta itemprop="name" content="Macon Daily"/>
					<meta itemprop="url" content="https://macondaily.com" />
 				</div>
				<!-- end article metadata -->

			</article>


			<!-- start Dianomi – sponsored content -->
			<iframe style="max-width:100%" width="654" height="787" scrolling="no" src="//www.dianomi.com/smartads.epl?id=2341"></iframe>
			<!-- end sponsored content -->

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://macondaily.com/2018/12/14/worldquant-millennium-quantitative-strategies-llc-buys-7786-shares-of-best-buy-co-inc-bby.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Worldquant Millennium Quantitative Strategies LLC Buys 7,786 Shares of Best Buy Co Inc (BBY)</p></div></a>				<a href="https://macondaily.com/2018/12/14/ralph-lauren-corp-rl-position-raised-by-point72-asset-management-l-p.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>Ralph Lauren Corp (RL) Position Raised by Point72 Asset Management L.P.</p></div></a>			
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>More Articles</h2>
			 				 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/national-bank-of-canada-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="National Bank of Canada  Insider Ricardo Pascoe Sells 49,884 Shares" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2018/12/14/national-bank-of-canada-na-insider-ricardo-pascoe-sells-49884-shares.html" rel="bookmark">National Bank of Canada  Insider Ricardo Pascoe Sells 49,884 Shares</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/carvana-co-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Carvana Co  Shares Bought by Point72 Asset Management L.P." />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2018/12/14/carvana-co-cvna-shares-bought-by-point72-asset-management-l-p.html" rel="bookmark">Carvana Co  Shares Bought by Point72 Asset Management L.P.</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/baiducom-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Baidu Inc  Shares Sold by Point72 Asia Singapore Pte. Ltd." />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2018/12/14/baidu-inc-bidu-shares-sold-by-point72-asia-singapore-pte-ltd.html" rel="bookmark">Baidu Inc  Shares Sold by Point72 Asia Singapore Pte. Ltd.</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/polo-ralph-lauren-corp-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Ralph Lauren Corp  Position Raised by Point72 Asset Management L.P." />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2018/12/14/ralph-lauren-corp-rl-position-raised-by-point72-asset-management-l-p.html" rel="bookmark">Ralph Lauren Corp  Position Raised by Point72 Asset Management L.P.</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/roku-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Point72 Hong Kong Ltd Buys 20,747 Shares of Roku Inc " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2018/12/14/point72-hong-kong-ltd-buys-20747-shares-of-roku-inc-roku.html" rel="bookmark">Point72 Hong Kong Ltd Buys 20,747 Shares of Roku Inc </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/british-american-tobacco-plc-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="British American Tobacco  Sets New 52-Week Low at $33.10" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2018/12/14/british-american-tobacco-bti-sets-new-52-week-low-at-33-10.html" rel="bookmark">British American Tobacco  Sets New 52-Week Low at $33.10</a>
				</div>
	 						</div><!-- end latest news -->

			<!-- start comments section -->
					
				
<div class="comments-box">
	<a name="comments" id="comments"></a>
	
<div id="respond">
	<h3>Leave a Reply</h3>
	<div class="cancel-comment-reply"> 
		<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/12/14/albemarle-alb-hits-new-1-year-low-at-84-01.html#respond" style="display:none;">Click here to cancel reply.</a></small>
	</div> 
			<form action="https://macondaily.com/wp-comments-post.php" method="post" id="commentform">
 			
			<p>
				<input type="text" name="author" class="txt" id="author" value="" size="22" tabindex="1" />
				<label for="author">Name  (Required) </label>
			</p>
			<p>
				<input type="text" name="email" class="txt" id="email" value="" size="22" tabindex="2" />
				<label for="email">Mail (will not be published)  (Required) </label>
			</p>
			<p>
				<input type="text" name="url" class="txt" id="url" value="" size="22" tabindex="3" />
				<label for="url">Website</label>
			</p>

						<p><textarea autocomplete="nope"  id="1b275b1ef5"  name="1b275b1ef5"   rows="10" cols="50" tabindex="4"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="nope" style="padding:0;clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script type="text/javascript">document.getElementById("comment").setAttribute( "id", "01734cb378fc1867a0a4219e43647e8d" );document.getElementById("1b275b1ef5").setAttribute( "id", "comment" );</script></p>
			<input name="submit" type="submit" id="submit" class="button" tabindex="5" value="Submit Comment" />
			<input type="hidden" name="comment_post_ID" value="1402819" />
			<input type='hidden' name='comment_post_ID' value='1402819' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
					</form> 
</div> 
</div> 			<!-- end comments section --> 


<!-- second ad spot -->


<br>
	</main> <!-- end main -->

	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-category-menu-header-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-748"><a href="https://macondaily.com/business">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-749"><a href="https://macondaily.com/technology">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-750"><a href="https://macondaily.com/health">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-751"><a href="https://macondaily.com/economy">Economy</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2006-2018 <a href="https://macondaily.com">Macon Daily</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://macondaily.com/wp-includes/js/wp-embed.min.js?ver=4.9.9'></script>
	
<!-- Start of StatCounter Code for Macon Daily -->
<script type="text/javascript">
var sc_project=11096465; 
var sc_invisible=1; 
var sc_security="ab3f5b90"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/11096465/0/ab3f5b90/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Macon Daily -->

		
	<!-- Start of StatCounter Code for Finance Articles -->
		<script type="text/javascript">
		var sc_project=9021069; 
		var sc_invisible=1; 
		var sc_security="fdde5482"; 
		var sc_https=1; 
		document.write("<sc"+"ript type='text/javascript' src='https://www.statcounter.com/counter/counter.js'></" + "script>");
		</script>
		<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/"></noscript>
		<!-- End of StatCounter Code for Finance Articles -->
		
<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=28152726&PostDate=2018-12-14&type=h&id=571967&domain=macondaily.com&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->


<!-- Start of StatCounter Code for Updated Articles -->
<!-- End of StatCounter Code for Updated Articles -->

<!-- One Signal Registration Code -->
<script type="text/javascript">
if(OneSignal.isPushNotificationsSupported())
{
    OneSignal.registerForPushNotifications();
}
</script>
<!-- End Registration Code -->


<!-- Default Statcounter code for Bing News Sites + ABMN http://www.americanbankingnews.com/ -->
<script type="text/javascript">
var sc_project=10694665; 
var sc_invisible=1; 
var sc_security="475eacb4"; 
var sc_https=1; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js" async></script>
<noscript><div class="statcounter"><a title="Web Analytics" href="http://statcounter.com/" target="_blank"><img class="statcounter" src="//c.statcounter.com/10694665/0/475eacb4/1/" alt="Web Analytics"></a></div></noscript>
<!-- End of Statcounter Code -->

	</body>

</html>