<!doctype html>
<html lang="en">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="e-74nzjb620pc06z1d1tss77m6jw1jrbf720-04c9gt5vnjifbqragbewjpnkem7hx6-n37obx7gzh2s41n6a09ys75ym4bge01zcdfxmy39brzeqelpo-7483m7g6k1" />
 <meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
 <meta name="google-site-verification" content="u8szh2ZiMut0IxmoUC8xfDZSyxxnVZPVlWcTnQ-rcD0" />
<meta name="viewport" content="width=1040">


<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script> 
<link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet">
<link rel="stylesheet" href="https://macondaily.com/wp-content/themes/alambre/style.css?1521124003" type="text/css" media="screen, projection" />

<link href="https://macondaily.com/feed" rel="alternate" title="Macon Daily RSS Feed" type="application/rss+xml" />
<link href="https://macondaily.com/feed/atom" rel="alternate" title="Macon Daily Atom Feed" type="application/atom+xml" />
<link href="https://macondaily.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://macondaily.com/wp-includes/css/dist/block-library/style.min.css?ver=5.0.4' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://macondaily.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://macondaily.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://macondaily.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Sanford C. Bernstein Raises BP (LON:BP) Price Target to GBX 710' href='https://macondaily.com/2019/08/08/sanford-c-bernstein-raises-bp-lonbp-price-target-to-gbx-710.html' />
<link rel='next' title='Citigroup Lowers ON Semiconductor (NASDAQ:ON) Price Target to $21.00' href='https://macondaily.com/2019/08/08/citigroup-lowers-on-semiconductor-nasdaqon-price-target-to-21-00.html' />
<meta name="generator" content="WordPress 5.0.4" />
<link rel="canonical" href="https://macondaily.com/2019/08/08/financial-contrast-china-sunergy-otcmktscsuny-vs-taiwan-semiconductor-mfg-otcmktstsm.html" />
<link rel='shortlink' href='https://macondaily.com/?p=1818924' />
<link rel="alternate" type="application/json+oembed" href="https://macondaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmacondaily.com%2F2019%2F08%2F08%2Ffinancial-contrast-china-sunergy-otcmktscsuny-vs-taiwan-semiconductor-mfg-otcmktstsm.html" />
<link rel="alternate" type="text/xml+oembed" href="https://macondaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmacondaily.com%2F2019%2F08%2F08%2Ffinancial-contrast-china-sunergy-otcmktscsuny-vs-taiwan-semiconductor-mfg-otcmktstsm.html&#038;format=xml" />
<link rel="amphtml" href="https://macondaily.com/2019/08/08/financial-contrast-china-sunergy-otcmktscsuny-vs-taiwan-semiconductor-mfg-otcmktstsm.html/amp" /><link rel="icon" href="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-04-65x65.png" sizes="32x32" />
<link rel="icon" href="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-04.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-04.png" />
<meta name="msapplication-TileImage" content="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-04.png" />

<!-- Start Meta Data -->

<title>Financial Contrast: China Sunergy (OTCMKTS:CSUNY) vs. Taiwan Semiconductor Mfg. (OTCMKTS:TSM) - Macon Daily</title>


<meta name="description" content="China Sunergy (OTCMKTS:CSUNY) and Taiwan Semiconductor Mfg. (NYSE:TSM) are both oils/energy companies, but which is the superior business? We will compare the two businesses based on the strength of their analyst recommendations, institutional ownership, dividends, earnings, profitability, valuation and risk. Dividends Taiwan Semiconductor Mfg. pays an annual dividend of $1.02 per share and has a [&hellip;]" />
<meta name="author" content="Nicolas Jordan">
<meta name="news_keywords" content="China Sunergy,OTCMKTS:CSUNY,CSUNY,Oils/Energy,comparison,review,stock comparison,stock analysis" />
<meta name="keywords" content="China Sunergy,OTCMKTS:CSUNY,CSUNY,Oils/Energy,comparison,review,stock comparison,stock analysis" />
<meta name="ticker" content="OTCMKTS:CSUNY" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@RatingsNetwork" />
<meta name="twitter:title" content="Financial Contrast: China Sunergy (OTCMKTS:CSUNY) vs. Taiwan Semiconductor Mfg. (OTCMKTS:TSM)"/>
<meta name="twitter:description" content="China Sunergy (OTCMKTS:CSUNY) and Taiwan Semiconductor Mfg. (NYSE:TSM) are both oils/energy companies, but which is the superior business? We will compare the two businesses based on the strength of their analyst recommendations, institutional ownership, dividends, earnings, profitability, valuation and risk. Dividends Taiwan Semiconductor Mfg. pays an annual dividend of $1.02 per share and has a [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/taiwan-semiconductor-manufacturing-company-ltd-logo.png" />

<!-- Open Graph Data -->
<meta property="og:title" content="Financial Contrast: China Sunergy (OTCMKTS:CSUNY) vs. Taiwan Semiconductor Mfg. (OTCMKTS:TSM)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://macondaily.com/2019/08/08/financial-contrast-china-sunergy-otcmktscsuny-vs-taiwan-semiconductor-mfg-otcmktstsm.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/taiwan-semiconductor-manufacturing-company-ltd-logo.png" />
<meta property="og:description" content="China Sunergy (OTCMKTS:CSUNY) and Taiwan Semiconductor Mfg. (NYSE:TSM) are both oils/energy companies, but which is the superior business? We will compare the two businesses based on the strength of their analyst recommendations, institutional ownership, dividends, earnings, profitability, valuation and risk. Dividends Taiwan Semiconductor Mfg. pays an annual dividend of $1.02 per share and has a [&hellip;]" />
<meta property="og:site_name" content="Macon Daily" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2019-08-08T03:56:43+0000" />
<meta property="article:modified_time" content="2019-08-08T03:56:43+0000" />
<meta property="article:tag" content="OTCMKTS:CSUNY" />
<meta property="article:tag" content="China Sunergy,OTCMKTS:CSUNY,CSUNY,Oils/Energy,comparison,review,stock comparison,stock analysis" />
<meta property="article:section" content="stock-market" />

<!-- Google meta is in the body-->


	<meta name="googlebot" content="unavailable_after: 2019-10-07T03:56:43+0000" />
<!-- End Meta Data -->

	
<script type='text/javascript'>var PopupAdChannel=''; </script>

  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'macondaily.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "cc650ee4-3f73-44da-89c4-1311e5ef1a43",
      safari_web_id: 'web.onesignal.auto.596e7d36-250c-4e22-98d4-39c9730f6c95', 
      autoRegister: true,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
  </script>

  <script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
	
<!-- Start IMS -->
<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13481304,
				sizes: [[300,250],[300,600],[300,1050]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'MaconDaily_ROS_RightRail_1'
			});
					});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		</script>
	<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
<!-- End IMS --> 

	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	

</head>

<body>

<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Macon Daily', 'macondaily.com', 'OTCMKTS:CSUNY', 'China Sunergy', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/generic-stocks.jpg');</script>
<!-- End MarketBeat Modern Popup -->

<!-- One Signal Registration Code -->
<script type="text/javascript">
if(OneSignal.isPushNotificationsSupported())
{
    OneSignal.registerForPushNotifications();
}
</script>
<!-- End Registration Code -->
	
<header>

	<div class="width-limiter add-padding"><!-- start: width-limiter with logo and space for alternate header unit -->
		<a class="logo-link" href="https://macondaily.com"><img id="logo" src="/wp-content/uploads/2018/02/macon-daily-transparent-01.png" alt="Macon Daily logo"></a>
<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit">
<script type="text/javascript">
google_ad_client = AdClientID;
    google_ad_slot = "6680372270";
google_ad_width = 728;
google_ad_height = 90;
google_ad_channel="9230018733,8569953935"</script>
<script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div> 

<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->

	<div id="menu">
		<div class="width-limiter" id="nav-main">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-category-menu-header" class="menu"><li id="menu-item-748" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-748"><a href="https://macondaily.com/business">Business</a></li>
<li id="menu-item-749" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-749"><a href="https://macondaily.com/technology">Technology</a></li>
<li id="menu-item-750" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-750"><a href="https://macondaily.com/health">Health</a></li>
<li id="menu-item-751" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-751"><a href="https://macondaily.com/economy">Economy</a></li>
</ul></nav>
			<nav class="navigation"><ul id="menu-top-pages" class="menu"><li id="menu-item-757" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-757"><a href="https://macondaily.com/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-758" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-758"><a href="https://macondaily.com/about-contact">About/Contact</a></li>
</ul></nav>
				<form id="searchform" action="https://macondaily.com/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" placeholder="Search" />
						<input class="searchsubmit" type="submit" value="" />
					</div>
				</form><!-- end: searchform -->
		</div> <!-- end: width-limiter for menu -->

	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter main-content">
		
<aside>
	
<!-- first square unit -->

<div class="ad336x280">
 <script type="text/javascript">
 google_ad_client = AdClientID;
 /* Ticker 300 */
    google_ad_slot = "2860492869";
 google_ad_width = 336;
 google_ad_height = 280;
 google_ad_channel="9230018733,9582167132"+PopupAdChannel; </script>
 <script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
 </script>
</div>

<!-- end first square unit -->

<!-- second square unit -->
<div class="ad336x280">
 <script type="text/javascript">
 google_ad_client = AdClientID;
 /* Ticker 300 */
google_ad_slot = "2860492869";
 google_ad_width = 336;
 google_ad_height = 280;
 google_ad_channel="9230018733,2058900337"+PopupAdChannel; </script>
 <script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
 </script>
</div>

<!-- end second square unit -->

<!-- Begin Dianomi Unit -->
<iframe width="336" height="670" scrolling="NO" src="//www.dianomi.com/smartads.epl?id=3356" style="width: 336px; border: none; overflow: hidden;"></iframe>
<!-- End Dianomi Unit -->
	
<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for China Sunergy</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for China Sunergy with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Macon Daily-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="OTCMKTS:CSUNY" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->


<div>
<a href="https://twitter.com/macondailynews" class="twitter-follow-button" data-show-count="false">Follow @macondailynews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</div>

<iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2FMacon-Daily-1815157661849118%2F&tabs=timeline&width=336&height=70&small_header=true&adapt_container_width=true&hide_cover=false&show_facepile=true&appId" width="336" height="70" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>


<!-- Start IMS -->
<div id="MaconDaily_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('MaconDaily_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- End IMS --> 

<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent Posts</h3>
            <ul>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/citigroup-lowers-on-semiconductor-nasdaqon-price-target-to-21-00.html">Citigroup Lowers ON Semiconductor (NASDAQ:ON) Price Target to $21.00</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/toshiba-tosyy-versus-its-rivals-critical-comparison.html">Toshiba (TOSYY) versus Its Rivals Critical Comparison</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/financial-contrast-china-sunergy-otcmktscsuny-vs-taiwan-semiconductor-mfg-otcmktstsm.html">Financial Contrast: China Sunergy (OTCMKTS:CSUNY) vs. Taiwan Semiconductor Mfg. (OTCMKTS:TSM)</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/sanford-c-bernstein-raises-bp-lonbp-price-target-to-gbx-710.html">Sanford C. Bernstein Raises BP (LON:BP) Price Target to GBX 710</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/international-consolidated-airlns-grp-loniag-stock-rating-upgraded-by-hsbc.html">International Consolidated Airlns Grp (LON:IAG) Stock Rating Upgraded by HSBC</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/wintrust-financial-nasdaqwtfc-and-international-bancshares-nasdaqiboc-critical-analysis.html">Wintrust Financial (NASDAQ:WTFC) and International Bancshares (NASDAQ:IBOC) Critical Analysis</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/hovde-group-lowers-german-american-bancorp-nasdaqgabc-to-market-perform-2.html">Hovde Group Lowers German American Bancorp. (NASDAQ:GABC) to Market Perform</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/hovde-group-lowers-german-american-bancorp-nasdaqgabc-to-market-perform.html">Hovde Group Lowers German American Bancorp. (NASDAQ:GABC) to Market Perform</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/jefferies-financial-group-lowers-daimler-otcmktsddaif-to-underperform.html">Jefferies Financial Group Lowers Daimler (OTCMKTS:DDAIF) to Underperform</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/citigroup-upgrades-endesa-s-a-adr-otcmktselezy-to-buy.html">Citigroup Upgrades ENDESA S A/ADR (OTCMKTS:ELEZY) to Buy</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/spotify-technology-nysespot-and-sirius-xm-nysesiri-head-to-head-contrast.html">Spotify Technology (NYSE:SPOT) and Sirius XM (NYSE:SIRI) Head-To-Head Contrast</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/ocado-group-lonocdo-receives-equal-weight-rating-from-morgan-stanley.html">Ocado Group (LON:OCDO) Receives Equal Weight Rating from Morgan Stanley</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/hsbc-lonhsba-pt-set-at-gbx-600-by-royal-bank-of-canada.html">HSBC (LON:HSBA) PT Set at GBX 600 by Royal Bank of Canada</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/citigroup-upgrades-metro-bank-otcmktsmbnkf-to-neutral.html">Citigroup Upgrades Metro Bank (OTCMKTS:MBNKF) to &#8220;Neutral&#8221;</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/german-american-bancorp-nasdaqgabc-upgraded-at-zacks-investment-research.html">German American Bancorp. (NASDAQ:GABC) Upgraded at Zacks Investment Research</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/dxp-enterprises-nasdaqdxpe-downgraded-by-zacks-investment-research.html">DXP Enterprises (NASDAQ:DXPE) Downgraded by Zacks Investment Research</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/mondi-lonmndi-price-target-cut-to-gbx-2000.html">Mondi (LON:MNDI) Price Target Cut to GBX 2,000</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/hsbcs-hsba-sell-rating-reiterated-at-deutsche-bank.html">HSBC&#8217;s (HSBA) &#8220;Sell&#8221; Rating Reiterated at Deutsche Bank</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/synthomers-synt-buy-rating-reaffirmed-at-peel-hunt.html">Synthomer&#8217;s (SYNT) Buy Rating Reaffirmed at Peel Hunt</a></li>
                        <li class="recent-posts"><a href="https://macondaily.com/2019/08/08/shore-capital-reaffirms-hold-rating-for-hsbc-lonhsba.html">Shore Capital Reaffirms &#8220;Hold&#8221; Rating for HSBC (LON:HSBA)</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->
		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://macondaily.com/2019/08/08/financial-contrast-china-sunergy-otcmktscsuny-vs-taiwan-semiconductor-mfg-otcmktstsm.html" />
				<div class="page-title">
				<h1 itemprop="headline">Financial Contrast: China Sunergy (OTCMKTS:CSUNY) vs. Taiwan Semiconductor Mfg. (OTCMKTS:TSM)</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://macondaily.com/author/nicolasj" title="Posts by Nicolas Jordan" rel="author">Nicolas Jordan</a></span></span> on <span itemprop="datePublished dateModified" content="2019-08-08T03:56:43+0000">Aug 8th, 2019</span> 
				</p><!--end .postmeta-->

				<!-- social sharing -->
				<div style="float:left; width:72px;">
				<a href="http://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-text="Financial Contrast: China Sunergy (OTCMKTS:CSUNY) vs. Taiwan Semiconductor Mfg. (OTCMKTS:TSM)" data-via="RatingsNetwork">Tweet</a>
				</div>
				<div style="float:left; width:85px;">
				<iframe src="https://www.facebook.com/plugins/share_button.php?href=https://macondaily.com/2019/08/08/financial-contrast-china-sunergy-otcmktscsuny-vs-taiwan-semiconductor-mfg-otcmktstsm.html&layout=button_count&size=small&mobile_iframe=true&appId=129801551471&width=87&height=20" width="87" height="20" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>
				</div>
				<div style="float:left; width:77px;">
				<script src="//platform.linkedin.com/in.js" type="text/javascript"> lang: en_US</script>
				<script type="IN/Share" data-counter="right"></script>
				</div>
										<div style="float:left;width:112px">
						<a href="https://api.stocktwits.com/widgets/share" id="stocktwits-share-button" data-text="Financial Contrast: China Sunergy (OTCMKTS:CSUNY) vs. Taiwan Semiconductor Mfg. (OTCMKTS:TSM) $CSUNY "><img src="https://api.stocktwits.com/assets/widget/stocktwits_share.png" alt="Share on StockTwits"/></a><script src="https://api.stocktwits.com/addon/button/share.min.js"></script>	
					</div>
	
				<div style="clear:both"></div>
				</div>
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p>China Sunergy (<a href='https://www.marketbeat.com/stocks/OTCMKTS/CSUNY/'>OTCMKTS:CSUNY</a>) and Taiwan Semiconductor Mfg. (<a href='https://www.marketbeat.com/stocks/NYSE/TSM/'>NYSE:TSM</a>) are both oils/energy companies, but which is the superior business? We will compare the two businesses based on the strength of their analyst recommendations, institutional ownership, dividends, earnings, profitability, valuation and risk. </p>
<p><strong style='text-decoration:underline'>Dividends</strong></p>


<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Macon Daily"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="OTCMKTS:CSUNY" />    <label for="InPostRegistrationEmail">Get <b>China Sunergy</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>
		


<p>Taiwan Semiconductor Mfg. pays an annual dividend of $1.02 per share and has a dividend yield of 2.5%. China Sunergy does not pay a dividend. Taiwan Semiconductor Mfg. pays out 45.5% of its earnings in the form of a dividend. Taiwan Semiconductor Mfg. has raised its dividend for 4 consecutive years. </p>

		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;">

<script type="text/javascript">
    google_ad_client = "ca-pub-9241026722326063";
    google_ad_slot = "2860492869";
    google_ad_width = 336;
    google_ad_height = 280;
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
                 </div>

					<p><strong style='text-decoration:underline'>Volatility &amp; Risk</strong></p>
<p>China Sunergy has a beta of 3.72, meaning that its stock price is 272% more volatile than the S&#038;P 500. Comparatively, Taiwan Semiconductor Mfg. has a beta of 1.02, meaning that its stock price is 2% more volatile than the S&#038;P 500. </p>
<p><strong style='text-decoration:underline'>Institutional &amp; Insider Ownership</strong></p>
<p>19.7% of Taiwan Semiconductor Mfg. shares are held by institutional investors. 1.1% of Taiwan Semiconductor Mfg. shares are held by insiders. Strong institutional ownership is an indication that large money managers, endowments and hedge funds believe a stock is poised for long-term growth.</p>
<p><strong  style='text-decoration:underline'>Analyst Ratings</strong></p>
<p>This is a summary of recent ratings and price targets for China Sunergy and Taiwan Semiconductor Mfg., as reported by MarketBeat. </p>
<table class='comparisontable'>
<tr>
<td></td>
<td><strong>Sell Ratings</td>
<td><strong>Hold Ratings</td>
<td><strong>Buy Ratings</td>
<td><strong>Strong Buy Ratings</td>
<td><strong>Rating Score</strong></td>
</tr>
<tr>
<td><strong>China Sunergy</strong></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>N/A</td>
</tr>
<tr>
<td><strong>Taiwan Semiconductor Mfg.</strong></td>
<td>0</td>
<td>1</td>
<td>2</td>
<td>0</td>
<td>2.67</td>
</tr>
</table>
<p>Taiwan Semiconductor Mfg. has a consensus target price of $50.00, suggesting a potential upside of 21.18%. Given Taiwan Semiconductor Mfg.&#8217;s  higher possible upside, analysts plainly believe Taiwan Semiconductor Mfg. is more favorable than China Sunergy.</p>
<p><strong style='text-decoration:underline'>Profitability</strong></p>
<p>This table compares China Sunergy and Taiwan Semiconductor Mfg.&#8217;s net margins, return on equity and return on assets.</p>
<table class='comparisontable'>
<tr>
<td></td>
<td><strong>Net Margins</strong></td>
<td><strong>Return on Equity</strong></td>
<td><strong>Return on Assets</strong></td>
</tr>
<tr>
<td><strong>China Sunergy</strong></td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td><strong>Taiwan Semiconductor Mfg.</strong></td>
<td>31.42%</td>
<td>19.01%</td>
<td>15.15%</td>
</tr>
</table>
<p><strong style='text-decoration:underline'>Valuation &amp; Earnings</strong></p>
<p>This table compares China Sunergy and Taiwan Semiconductor Mfg.&#8217;s top-line revenue, earnings per share (EPS) and valuation.</p>
<table class='comparisontable'>
<tr>
<td></td>
<td><strong>Gross Revenue</strong></td>
<td><strong>Price/Sales Ratio</strong></td>
<td><strong>Net Income</strong></td>
<td><strong>Earnings Per Share</strong></td>
<td><strong>Price/Earnings Ratio</strong></td>
</tr>
<tr>
<td><strong>China Sunergy</strong></td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td><strong>Taiwan Semiconductor Mfg.</strong></td>
<td>$34.20 billion</td>
<td>6.26</td>
<td>$11.86 billion</td>
<td>$2.24</td>
<td>18.42</td>
</tr>
</table>
<p>Taiwan Semiconductor Mfg. has higher revenue and earnings than China Sunergy. </p>
<p><strong style='text-decoration:underline'>Summary</strong></p>
<p>Taiwan Semiconductor Mfg. beats China Sunergy on 10 of the 12 factors compared between the two stocks.</p>
<p><strong style='text-decoration:underline'>China Sunergy Company Profile</strong></p>
<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/generic-stocks.jpg" alt="China Sunergy logo" title="China Sunergy logo" class="companylogo" />China Sunergy Co., Ltd., together with its subsidiaries, designs, develops, manufactures, and markets solar cells and modules in the People&#x27;s Republic of China and internationally. The company offers monocrystalline and multicrystalline silicon solar cells; and standard P-type solar cells, HP solar cells, and emitter cells, as well as solar modules for use in a range of residential, commercial, industrial, and other solar power generation systems. It also invests in, develops, and operates solar power projects. The company sells its products to system integrators, solar power project developers, and solar power product distributors under the CSUN brand name, as well as on an original equipment manufacturing basis. China Sunergy Co., Ltd. was founded in 2004 and is headquartered in Nanjing, the People&#x27;s Republic of China.</p>
<p><strong style='text-decoration:underline'>Taiwan Semiconductor Mfg. Company Profile</strong></p>
<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/taiwan-semiconductor-manufacturing-company-ltd-logo.png" alt="Taiwan Semiconductor Mfg. logo" title="Taiwan Semiconductor Mfg. logo" class="companylogo" />Taiwan Semiconductor Manufacturing Company Limited, together with its subsidiaries, engages in manufacturing, selling, packaging, testing, and computer-aided design of integrated circuits and other semiconductor devices. The company manufactures masks and electronic spare parts; researches, develops, designs, manufactures, sells, packages, and tests color filters; and offers customer and engineering support services. It is also involved in investing activities. The company operates in North America, China, Japan, Asia Pacific, Europe, the Middle East, and Africa. Taiwan Semiconductor Manufacturing Company Limited was founded in 1987 and is headquartered in HsinChu, Taiwan.<!--ViewCount:ArticleHistoryID=37696136&PostDate=2019-8-8&type=y&quarternary=1&id=159119--></p>
<p><!--Keyword: China Sunergy,OTCMKTS:CSUNY,CSUNY,Oils/Energy,comparison,review,stock comparison,stock analysis--></p>

			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for China Sunergy Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for China Sunergy and related companies with <a href="/daily-email-updates-basic/?symbol=OTCMKTS:CSUNY&c=China+Sunergy" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Macon Daily-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="OTCMKTS:CSUNY" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				<!--/sse-->
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=300&h=300&zc=1&src=https://www.marketbeat.com/logos/taiwan-semiconductor-manufacturing-company-ltd-logo.png" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://macondaily.com/wp-content/uploads/2018/02/macon-daily-transparent-01.png">
 						<meta itemprop="height" content="90">
						 <meta itemprop="width" content="280">
					 </div>
					<meta itemprop="name" content="Macon Daily"/>
					<meta itemprop="url" content="https://macondaily.com" />
 				</div>
				<!-- end article metadata -->

			</article>

<!-- IMS below post -->
		<div id="MaconDaily_ROS_BelowPost_1"></div><br><br>
<!-- end IMS below post -->	
		
			<!-- start Dianomi – sponsored content -->
			<iframe style="max-width:100%" width="654" height="787" scrolling="no" src="//www.dianomi.com/smartads.epl?id=2341"></iframe>
			<!-- end sponsored content -->

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://macondaily.com/2019/08/08/sanford-c-bernstein-raises-bp-lonbp-price-target-to-gbx-710.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Sanford C. Bernstein Raises BP (LON:BP) Price Target to GBX 710</p></div></a>				<a href="https://macondaily.com/2019/08/08/citigroup-lowers-on-semiconductor-nasdaqon-price-target-to-21-00.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>Citigroup Lowers ON Semiconductor (NASDAQ:ON) Price Target to $21.00</p></div></a>			
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>More Articles</h2>
			 				 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/on-semiconductor-corp-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Citigroup Lowers ON Semiconductor  Price Target to $21.00" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2019/08/08/citigroup-lowers-on-semiconductor-nasdaqon-price-target-to-21-00.html" rel="bookmark">Citigroup Lowers ON Semiconductor  Price Target to $21.00</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Toshiba  versus Its Rivals Critical Comparison" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2019/08/08/toshiba-tosyy-versus-its-rivals-critical-comparison.html" rel="bookmark">Toshiba  versus Its Rivals Critical Comparison</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/taiwan-semiconductor-manufacturing-company-ltd-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Financial Contrast: China Sunergy  vs. Taiwan Semiconductor Mfg. " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2019/08/08/financial-contrast-china-sunergy-otcmktscsuny-vs-taiwan-semiconductor-mfg-otcmktstsm.html" rel="bookmark">Financial Contrast: China Sunergy  vs. Taiwan Semiconductor Mfg. </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/bp-plc-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Sanford C. Bernstein Raises BP  Price Target to GBX 710" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2019/08/08/sanford-c-bernstein-raises-bp-lonbp-price-target-to-gbx-710.html" rel="bookmark">Sanford C. Bernstein Raises BP  Price Target to GBX 710</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/international-consolidated-airlines-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="International Consolidated Airlns Grp  Stock Rating Upgraded by HSBC" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2019/08/08/international-consolidated-airlns-grp-loniag-stock-rating-upgraded-by-hsbc.html" rel="bookmark">International Consolidated Airlns Grp  Stock Rating Upgraded by HSBC</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/international-bancshares-corporation-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Wintrust Financial  and International Bancshares  Critical Analysis" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://macondaily.com/2019/08/08/wintrust-financial-nasdaqwtfc-and-international-bancshares-nasdaqiboc-critical-analysis.html" rel="bookmark">Wintrust Financial  and International Bancshares  Critical Analysis</a>
				</div>
	 						</div><!-- end latest news -->

<!-- second ad spot -->


<br>
	</main> <!-- end main -->

	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-category-menu-header-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-748"><a href="https://macondaily.com/business">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-749"><a href="https://macondaily.com/technology">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-750"><a href="https://macondaily.com/health">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-751"><a href="https://macondaily.com/economy">Economy</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2006-2019 <a href="https://macondaily.com">Macon Daily</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://macondaily.com/wp-includes/js/wp-embed.min.js?ver=5.0.4'></script>
	
<!-- Start of StatCounter Code for Macon Daily -->
<script type="text/javascript">
var sc_project=11096465; 
var sc_invisible=1; 
var sc_security="ab3f5b90"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/11096465/0/ab3f5b90/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Macon Daily -->

<!-- Start of StatCounter Code for Finance Articles -->
<script type="text/javascript">
	var sc_project=9021069; 
	var sc_invisible=1; 
	var sc_security="fdde5482"; 
	var sc_https=1; 
	document.write("<sc"+"ript type='text/javascript' src='https://www.statcounter.com/counter/counter.js'></" + "script>");
</script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/"></noscript>
<!-- End of StatCounter Code for Finance Articles -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=37695336&PostDate=2019-8-8&type=y&quarternary=1&id=159160&domain=macondaily.com&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->


<!-- Start of StatCounter Code for Updated Articles -->
<!-- End of StatCounter Code for Updated Articles -->

<!-- Default Statcounter code for Bing News Sites + ABMN http://www.americanbankingnews.com/ -->
<script type="text/javascript">
var sc_project=10694665; 
var sc_invisible=1; 
var sc_security="475eacb4"; 
var sc_https=1; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js" async></script>
<noscript><div class="statcounter"><a title="Web Analytics" href="http://statcounter.com/" target="_blank"><img class="statcounter" src="//c.statcounter.com/10694665/0/475eacb4/1/" alt="Web Analytics"></a></div></noscript>
<!-- End of Statcounter Code -->


	</body>

</html>